Sponsored

ABS light, Service AdvanceTrac, Park Aid Fault, etc

centra28

Badlands
Well-Known Member
First Name
Dale
Joined
Jul 24, 2020
Threads
13
Messages
636
Reaction score
1,367
Location
Kansas City, MO
Vehicle(s)
2021 Jeep Gladiator Mojave
Your Bronco Model
Badlands
Clubs
 
I will have had my Bronco for 4 weeks tomorrow (picked up with 7 miles on Sat 7/16/22). I have less than 800 miles, and 100% stock 4 door Badlands Sasquatch with the 2.7 L v6 and High Package.

I was driving on the highway in ECO mode, just normal driving. Someone slides in front of me at an uncomfortable distance, so I press the brake to slow a little. When I pressed the brake it felt like the ABS was engaging. I felt a quick click click click in the pedal, and it just sounded weird. I did not slam the brakes or anything weird, it was a normal soft press to grow distance between me and the vehicle in front of me. I switched lanes, slowed down a little more and heard a similar noise then all of these warning lights kicked in:

  • Antilock Brake Fault
  • Pre-Collision Assist Not Available
  • Service AdvanceTrac

It all happened so quick I wasn't able to read all of the messages in detail, but it also said driver mode disengaged, or no longer available and switched me back to normal drive mode. There was also a message that the traction control and ABS was disengaged.

Other than the initial weird clicking and disengaging the drive mode, the vehicle was driving fine, just with 3 warning lights above. I pulled off at the nearest exit and stopped to turn the vehicle off then on (hoping it would reset). When I did I also received a "Park Aid Fault". I was able to get a couple of pictures of the warning lights and fault messages at this point.

1659758852090.png


1659758824162.png


I tried turning the vehicle off (letting it shut down completely) and then back on a couple times but I still kept getting the same alerts. Fortunately I was able to drive home. When I got home I turned it off and just left it for a while. I went back a few hours later, hoping that it would magically be fine, but it's not! Now I have additional fault messages. I noticed that received the messages to my Ford Pass app on the initial faults. I read the messages and the solutions on how to fix. They didn't apply, so they weren't really helpful. I will post them too.


1659758911264.png


-The tires are the stock Sasquatch wheels/tires

1659758964971.png


-The grill was clean, but I did wipe it down just to be sure (to no avail)

Total alerts going on at this point (and it's just all out of the blue! literally nothing rough or weird, I didn't run into anything or run over a puddle. I was literally just driving home from work like any other day.)

  • Park Aid Fault
  • Antilock Brake Fault
  • Pre-Collision Assist Not Available
  • Service AdvanceTrac
  • Park Break Fault Service Now
  • Drive Mode Not Available (I cannot switch drive modes)
I am going to check with the dealer tomorrow, see if they can get me in to have service take a look. I am hoping it's an easy computer reset - but I will keep everyone posted. I tried to search the forums for some similar issues, but I didn't come up with anything. The closest thing I saw was a thread on a thumping noise coming from the rear of the vehicle. After I pulled back onto the highway with the faults I did hear a weird thump, but I couldn't tell if it was some debris from the road or the vehicle itself. I'll be keeping my ears out for that as well.

Pics to come, and will update once I talk to the dealer. Hope that nobody else has these issues.

some additional faults once I got home:
1659759076460.png

1659759115087.png

1659759140731.png

1659759159256.png






 
Last edited:
OP
OP
centra28

centra28

Badlands
Well-Known Member
First Name
Dale
Joined
Jul 24, 2020
Threads
13
Messages
636
Reaction score
1,367
Location
Kansas City, MO
Vehicle(s)
2021 Jeep Gladiator Mojave
Your Bronco Model
Badlands
Clubs
 
Thanks, that is reassuring!
 

Ford Motor Company

First Edition
Well-Known Member
Official Ford Account
First Name
Ford
Joined
May 25, 2021
Threads
5
Messages
2,224
Reaction score
4,597
Location
Dearborn
Vehicle(s)
Bronco, Bronco Sport
Your Bronco Model
First Edition
I will have had my Bronco for 4 weeks tomorrow (picked up with 7 miles on Sat 7/16/22). I have less than 800 miles, and 100% stock 4 door Badlands Sasquatch with the 2.7 L v6 and High Package.

I was driving on the highway in ECO mode, just normal driving. Someone slides in front of me at an uncomfortable distance, so I press the brake to slow a little. When I pressed the brake it felt like the ABS was engaging. I felt a quick click click click in the pedal, and it just sounded weird. I did not slam the brakes or anything weird, it was a normal soft press to grow distance between me and the vehicle in front of me. I switched lanes, slowed down a little more and heard a similar noise then all of these warning lights kicked in:

  • Antilock Brake Fault
  • Pre-Collision Assist Not Available
  • Service AdvanceTrac

It all happened so quick I wasn't able to read all of the messages in detail, but it also said driver mode disengaged, or no longer available and switched me back to normal drive mode. There was also a message that the traction control and ABS was disengaged.

Other than the initial weird clicking and disengaging the drive mode, the vehicle was driving fine, just with 3 warning lights above. I pulled off at the nearest exit and stopped to turn the vehicle off then on (hoping it would reset). When I did I also received a "Park Aid Fault". I was able to get a couple of pictures of the warning lights and fault messages at this point.

1659758852090.png


1659758824162.png


I tried turning the vehicle off (letting it shut down completely) and then back on a couple times but I still kept getting the same alerts. Fortunately I was able to drive home. When I got home I turned it off and just left it for a while. I went back a few hours later, hoping that it would magically be fine, but it's not! Now I have additional fault messages. I noticed that received the messages to my Ford Pass app on the initial faults. I read the messages and the solutions on how to fix. They didn't apply, so they weren't really helpful. I will post them too.


1659758911264.png


-The tires are the stock Sasquatch wheels/tires

1659758964971.png


-The grill was clean, but I did wipe it down just to be sure (to no avail)

Total alerts going on at this point (and it's just all out of the blue! literally nothing rough or weird, I didn't run into anything or run over a puddle. I was literally just driving home from work like any other day.)

  • Park Aid Fault
  • Antilock Brake Fault
  • Pre-Collision Assist Not Available
  • Service AdvanceTrac
  • Park Break Fault Service Now
  • Drive Mode Not Available (I cannot switch drive modes)
I am going to check with the dealer tomorrow, see if they can get me in to have service take a look. I am hoping it's an easy computer reset - but I will keep everyone posted. I tried to search the forums for some similar issues, but I didn't come up with anything. The closest thing I saw was a thread on a thumping noise coming from the rear of the vehicle. After I pulled back onto the highway with the faults I did hear a weird thump, but I couldn't tell if it was some debris from the road or the vehicle itself. I'll be keeping my ears out for that as well.

Pics to come, and will update once I talk to the dealer. Hope that nobody else has these issues.

some additional faults once I got home:
1659759076460.png

1659759115087.png

1659759140731.png

1659759159256.png
Hi there! Will you send us a message with your VIN and your local Ford dealer? I can look into things on my end.
 
OP
OP
centra28

centra28

Badlands
Well-Known Member
First Name
Dale
Joined
Jul 24, 2020
Threads
13
Messages
636
Reaction score
1,367
Location
Kansas City, MO
Vehicle(s)
2021 Jeep Gladiator Mojave
Your Bronco Model
Badlands
Clubs
 
Hi there! Will you send us a message with your VIN and your local Ford dealer? I can look into things on my end.
sent!

update: the faults all cleared this morning on the way over to the dealer but they are going to check it out anyways. my dealer is awesome.
 

Sponsored

Electricjd

Wildtrak
Member
First Name
El
Joined
Aug 8, 2022
Threads
0
Messages
14
Reaction score
5
Location
California
Vehicle(s)
2022 Wildtrak
Your Bronco Model
Wildtrak
Same problems here. 2022 Wildtrak. I get the “clicking” brake pedal and then a bunch of messages that say the brakes do not work properly. Had at the dealer twice, last time for a week to see if they could replicate. My dealer has been very supportive but has no answers. My wife doesn’t want to drive it thinks the brakes will not work because of a computer error . . . Not sure I disagree with her. Not to mention I get a weekly hill start descent alert on MyFord app.

790341B0-EBA4-4BC6-A96D-C0659B650BF8.jpeg


40596794-7DFE-4783-A48C-192C9AF7E6DE.jpeg


477093EB-8F6A-487A-AE35-BDADB271A4CF.jpeg


FDDFDAEE-8590-405E-9903-1128528C53F4.jpeg


83B99457-FE2F-4B79-AA48-41C62D63F58B.jpeg
 

Glow6903

Black Diamond
New Member
First Name
Matthew
Joined
Aug 8, 2022
Threads
0
Messages
1
Reaction score
0
Location
Connecticut
Vehicle(s)
2022 4 door Black Diamond
Your Bronco Model
Black Diamond
I had the same issue. It was a loose connection on my driver side front tire area. Luckily my father is a mechanic and he put it on the computer. He actually may have knocked it loose when he was running the wire for the trailer lights from the front to the back

C82AA5E6-7B59-4F5B-8F69-752F596DEE98.png


 

‘21OBX

Outer Banks
Well-Known Member
First Name
Ken
Joined
Jan 24, 2022
Threads
92
Messages
2,404
Reaction score
3,006
Location
90Bronco19
Vehicle(s)
2021 bronco outer banks
Your Bronco Model
Outer Banks
Clubs
 
If your comfortable check the three (8mm head bolts ?) under the fuse box cover. Some have had them left loose at the factory. They don’t need to be he man tight but should be lightly snug.
On the high package our collision avoidance is camera based which is up on the windshield near the rear view mirror.
 

Electricjd

Wildtrak
Member
First Name
El
Joined
Aug 8, 2022
Threads
0
Messages
14
Reaction score
5
Location
California
Vehicle(s)
2022 Wildtrak
Your Bronco Model
Wildtrak
Thanks. I checked and snugged the 3 bolts (6mm) and I looked in front fender well for clip (couldn’t see any). Appreciate it.
 

Ford Motor Company

First Edition
Well-Known Member
Official Ford Account
First Name
Ford
Joined
May 25, 2021
Threads
5
Messages
2,224
Reaction score
4,597
Location
Dearborn
Vehicle(s)
Bronco, Bronco Sport
Your Bronco Model
First Edition
Same problems here. 2022 Wildtrak. I get the “clicking” brake pedal and then a bunch of messages that say the brakes do not work properly. Had at the dealer twice, last time for a week to see if they could replicate. My dealer has been very supportive but has no answers. My wife doesn’t want to drive it thinks the brakes will not work because of a computer error . . . Not sure I disagree with her. Not to mention I get a weekly hill start descent alert on MyFord app.
Hi there. Can you please send over a private message with your VIN with the name and location of your local Ford dealer? I'd like to see what I can do to assist with your Bronco's brake concerns.
 

Sponsored

Badness

Badlands
Active Member
First Name
Seth
Joined
Feb 17, 2022
Threads
4
Messages
26
Reaction score
170
Location
Texas
Vehicle(s)
2021 Bronco Badlands, 1968 FJ40
Your Bronco Model
Badlands
I experienced these same faults a few months back, discovered a wire loosely connected on the inside of the rear hub assembly. (Was doing some high speed off-roading prior to the faults) Simply unplugged it and plugged it back in and everything went back to normal. No further issues since.
 

Electricjd

Wildtrak
Member
First Name
El
Joined
Aug 8, 2022
Threads
0
Messages
14
Reaction score
5
Location
California
Vehicle(s)
2022 Wildtrak
Your Bronco Model
Wildtrak
Message sent. Thanks for checking into it. Appreciate it.

Hi there. Can you please send over a private message with your VIN with the name and location of your local Ford dealer? I'd like to see what I can do to assist with your Bronco's brake concerns.
 

Mbquick

Outer Banks
New Member
First Name
Brooks
Joined
Jan 27, 2022
Threads
1
Messages
2
Reaction score
2
Location
Myrtle Beach
Vehicle(s)
21 bronco obx
Your Bronco Model
Outer Banks
I’m having the exact same issues with a 21 obx 2.7
It’s been at the dealership since Monday and after hearing any news or an update I called them today and was told they don’t know anything yet. It’s becoming very frustrating.

B3C63D40-BD3B-477C-B83A-649882918770.jpeg


BE8151EA-7355-4E0A-9071-3AAD27464DB3.jpeg


B72F5E57-A68E-49D7-890A-F70EE8ACEE57.jpeg
 
First Name
Matthew
Joined
Feb 6, 2021
Threads
2
Messages
23
Reaction score
168
Location
Montara
Vehicle(s)
Badlands and Toyota Highlander
Your Bronco Model
Badlands
Clubs
 
Hi there. Can you please send over a private message with your VIN with the name and location of your local Ford dealer? I'd like to see what I can do to assist with your Bronco's brake concerns.
Hi Ford Motor Company,

Thanks for showing interest in these peoples issues.

I am wondering if you could get an actual engine engineer to weigh in on why the owners manual has had 7qts for engine oil fill capacity for 2.7L published for two years all of a sudden change to 6qts? Also get them to explain why our broncos are 7.5 qt filled from factory? I understand that you all sent out SSMs to change but would really like the design professionals to explain why it changed as it doesn’t seem to make sense to a whole lot of us.

I spent $60,000 dollars (more with interest after life of loan) really enjoy driving the bronco, and want to have it for as long as possible.

Thank you
 

largo88

Black Diamond
Member
Joined
Mar 30, 2021
Threads
1
Messages
12
Reaction score
13
Location
Indiana
Vehicle(s)
2007 Tundra, 2015 Highlander, 2022 Bronco
Your Bronco Model
Black Diamond
I've got the brake flake too. Black Diamond Wildtrak Sasquatch. At least that's what the stickers say - got a Black Diamond on the driver side and Wildtrak Squatch on the other side. Should be Black Diamond. 2.7, mid with ~1200 miles.

Happened the first time 4-5 days after I got it. Shut it off then waited 30 seconds for Windows to shutdown (just kidding) then restarted and it went away. Then it happened two times in the last week about a couple days apart from each other - same location which was odd (relatively flat) around 6pm.

Every time it ends up the same with the brake light on. The first time it cleared by restarting the engine. The last two times the brake light didn't turn off, I tried to "turn off" the parking brake; it told me the parking brake was on but then never said off after I pulled the switch/lever again. When I put it in drive you can tell the brakes are on but let go when you press on the accelerator. Seems to drive normally after that but don't want to push my luck with ABS and Pre-collision Assist.

I get the following messages on the display:
Service AdvanceTrac
Pre-Collision Assist Not Available
Hills Start Assist Not Available
Check Brake System

Actually, we tried going doorless for the first time on Friday and that did seem to make it angrier - I think we had it two times that evening.

Never taken off-road. Actually I don't think it's ever been on grass or even gravel. It's a sad Bronco.

Taking it into the dealer tomorrow morning. Wish me luck.
Sponsored

 

Sponsored

 
Sponsored
Top