Sponsored

Multiple Failure Alerts!

BigSkyBronco

Badlands
Well-Known Member
First Name
Chris
Joined
Oct 27, 2021
Threads
11
Messages
198
Reaction score
251
Location
Big Sky Country
Vehicle(s)
'06 Wrangler Rubicon Unlimited - '96 Toyota FZJ80
Your Bronco Model
Badlands
Clubs
 
Yesterday I was just out running some errands and 3 miles into my trip my screen alerts me to the following:

Ford Bronco Multiple Failure Alerts! IMG_3364
Ford Bronco Multiple Failure Alerts! IMG_3365
Ford Bronco Multiple Failure Alerts! IMG_3366
Ford Bronco Multiple Failure Alerts! IMG_3367


These all came on within seconds of each other while driving down a dry but cold road in 2WD. After I got to my destination, shut down & then restarted my Bronco, there were no warnings in sight until...... about three minutes later. Then, a repeat of the original s#it show!
My small town dealer says bring it in, we can get to it in 3 weeks. That is when I already had an appointment for my Wiper Software Update. If I hadn't had that appointment already, I'd be looking at June. I'm not sure I can adequately express my severe lack of satisfaction with this Ford product and the service department of my dealership. 2023 BL 2.7
Sponsored

 

Boreal

Badlands
Well-Known Member
First Name
Colby
Joined
Oct 4, 2021
Threads
9
Messages
873
Reaction score
2,831
Location
MB
Website
www.cspencephoto.com
Vehicle(s)
2022 Badlands 2DR
Your Bronco Model
Badlands
OP
OP
BigSkyBronco

BigSkyBronco

Badlands
Well-Known Member
First Name
Chris
Joined
Oct 27, 2021
Threads
11
Messages
198
Reaction score
251
Location
Big Sky Country
Vehicle(s)
'06 Wrangler Rubicon Unlimited - '96 Toyota FZJ80
Your Bronco Model
Badlands
Clubs
 
Continuing to bless us in this forum, good on ya Flip
Yes, I am blessed by a stranger. Thanks to Flip's input my Bronco now seems to run as intended. Now its my turn to pay it forward 🙂
 

TRACKTOY

Badlands
Well-Known Member
First Name
ANDRÉ
Joined
Sep 28, 2020
Threads
16
Messages
308
Reaction score
312
Location
ST-AUGUSTIN-DE-DESMAURES Qc. CANADA
Vehicle(s)
F150 LARIAT CREW C. 3.5L ÉCO 2022+ BRONCO BL.2023
Your Bronco Model
Badlands
Clubs
 
HELLO
The same problem occurred on my 2017 F150 XLT because a mouse chewed a wire on my rear differential = no guarantee you pay and the dealer after finding the problem will repair it.
tracktoy
 

Sponsored

TRACKTOY

Badlands
Well-Known Member
First Name
ANDRÉ
Joined
Sep 28, 2020
Threads
16
Messages
308
Reaction score
312
Location
ST-AUGUSTIN-DE-DESMAURES Qc. CANADA
Vehicle(s)
F150 LARIAT CREW C. 3.5L ÉCO 2022+ BRONCO BL.2023
Your Bronco Model
Badlands
Clubs
 
YEAH. It cost me $125.00 CDN I'm lucky I had a good mechanic he found the problem immediately. Nothing to SEE with Ford. But he could have worked several hours before finding the problem. So you will be paid for his search for the problem. Not funny at all, I feel sorry for you.
TRACKTOY
 

orion

Black Diamond
Well-Known Member
First Name
Jeremy
Joined
Nov 23, 2020
Threads
12
Messages
829
Reaction score
1,694
Location
Colorado
Vehicle(s)
17' F-250, 17' Explorer
Your Bronco Model
Black Diamond
Clubs
 
Yes, I am blessed by a stranger. Thanks to Flip's input my Bronco now seems to run as intended. Now its my turn to pay it forward 🙂
So what transpired between your first post and this post so people know the fix if having similar problems?
 

BigBlue7

Black Diamond
Well-Known Member
Joined
Aug 6, 2023
Threads
10
Messages
287
Reaction score
694
Location
New Jersey
Vehicle(s)
‘23 Black Diamond Sasquatch
Your Bronco Model
Black Diamond
What are your voltage readings on your dash?

I had similar alerts along with service charging system. Turned out to be loose terminals on the control module under the battery coming from the alternator
 
OP
OP
BigSkyBronco

BigSkyBronco

Badlands
Well-Known Member
First Name
Chris
Joined
Oct 27, 2021
Threads
11
Messages
198
Reaction score
251
Location
Big Sky Country
Vehicle(s)
'06 Wrangler Rubicon Unlimited - '96 Toyota FZJ80
Your Bronco Model
Badlands
Clubs
 
So what transpired between your first post and this post so people know the fix if having similar problems?
I had installed a Pedal Commander about 10 months ago. I had never had any problems but after hearing from @flip I decided to remove it. At the same time I disconnected my battery for a couple of hours.
Upon restart I was left with only the CEL. My app indicated that the only remaining issue was the a disagreement between the two throttle position sensors. Its going to the dealer in few weeks to hopefully sort that out and for the wiper software:mad: update.
 

Sponsored

LT. DAN ICE CREAM!!!

Badlands
Well-Known Member
Joined
Aug 7, 2021
Threads
0
Messages
127
Reaction score
329
Location
Philadelphia, PA
Vehicle(s)
2021 Badlands
Your Bronco Model
Badlands
Clubs
 
Did Ford do a recent stealth OTA update? I had the exact same set of errors happen to my Bronco on Sunday the 11th.
 
OP
OP
BigSkyBronco

BigSkyBronco

Badlands
Well-Known Member
First Name
Chris
Joined
Oct 27, 2021
Threads
11
Messages
198
Reaction score
251
Location
Big Sky Country
Vehicle(s)
'06 Wrangler Rubicon Unlimited - '96 Toyota FZJ80
Your Bronco Model
Badlands
Clubs
 
Update…….
I didn’t drive my Bronco for a week and when I started it, no CEL! All appears normal now but it’s still going to the dealer for the wiper software update.

I had installed a Pedal Commander about 10 months ago. I had never had any problems but after hearing from @flip I decided to remove it. At the same time I disconnected my battery for a couple of hours.
Upon restart I was left with only the CEL. My app indicated that the only remaining issue was the a disagreement between the two throttle position sensors. Its going to the dealer in few weeks to hopefully sort that out and for the wiper software:mad: update.
 

Sherminiator

Big Bend
Well-Known Member
First Name
Scott
Joined
Aug 21, 2017
Threads
63
Messages
1,520
Reaction score
2,178
Location
CNJ
Vehicle(s)
2022 Ford Bronco Big Bend
Your Bronco Model
Big Bend
Clubs
 
Mine did that once, but it was driver error-I was parked and power cycled the car oddly (can't remember what I did, but I had my foot on and off the brake for some reason) and all these warnings came up. I shut the car down, let it sit powered off for 30 seconds and restarted and it cleared up and never popped up again.

I had an issue with my SHO telling me to service advancedtrac once in a great while like this, and stopping and restarting the car fixed it. I attributed it to sensors just not being in the exact correct position.
 

HeliPilot

Badlands
Well-Known Member
First Name
Kenny
Joined
Dec 17, 2021
Threads
13
Messages
1,189
Reaction score
2,523
Location
CT
Vehicle(s)
2022 2.7L SAS
Your Bronco Model
Badlands
Update…….
I didn’t drive my Bronco for a week and when I started it, no CEL! All appears normal now but it’s still going to the dealer for the wiper software update.
Usually it takes a couple cycles for CELs to clear once the issue is resolved. Glad it worked out.
 

Coldsmoke

Badlands
Well-Known Member
First Name
Knuckles
Joined
Dec 15, 2020
Threads
4
Messages
512
Reaction score
1,535
Location
Northern Illinois
Vehicle(s)
Ford F150 Lariat
Your Bronco Model
Badlands
Clubs
 
I worked in the computer industry for 40 years and it’s amazing how many issues can be resolved by either the “three finger salute”, (ctrl-alt-del), or by pulling the plug for 30 seconds. We need the equivalent on our Broncos.
…..and we’re worried about AI taking over society……. Just kick the plug out. 😁
Sponsored

 
 



Top