Yakima EXO System on a Sasquatch Badlands

Quick

First Edition
Well-Known Member
Joined
Jan 2, 2022
Threads
8
Messages
83
Reaction score
86
Location
CT
Vehicle(s)
21 First Edition
Bronco
First Edition
Thats not much weight at all really. I'm skeptical even lightly loaded this thing would survive the fairly severe jostling it takes to get to some of our campsites. My thought was to get the gearbox.
I think the hitch would be fine - that thing is *beefy*.

The problem for my use case is the gear box isn't wide enough - my skis are 187cm long.

 

SDBroncoWT

Wildtrak
New Member
First Name
Ron
Joined
Feb 26, 2022
Threads
0
Messages
3
Reaction score
1
Location
San Diego
Vehicle(s)
4Door Bronco WT
Bronco
Wildtrak
Thought I would post some pics of a slightly different setup. OE Hitch with a 9" extension from Amazon. It fits perfectly with the spare, even with the ski rack setup which protrudes towards the tire.

Another option would have been to mount the skis on the bottom and the box on top with the shorter 7" extension, but I didn't want the skis in the path of the debris from the tires.

YakimaEXO - 1.jpeg


YakimaEXO - 2.jpeg


YakimaEXO - 3.jpeg
do you have any images of a rear shot?

wondering if I need the light and plate kit.
 

Quick

First Edition
Well-Known Member
Joined
Jan 2, 2022
Threads
8
Messages
83
Reaction score
86
Location
CT
Vehicle(s)
21 First Edition
Bronco
First Edition
do you have any images of a rear shot?

wondering if I need the light and plate kit.
Unfortunately I don't have any from the rear. However, with the setup I have the lights aren't blocked (you can see in the pics), but the license plate is. Personally, it's not a concern for me and I have no plans to get either of those options.
 

JJ Bronco

Big Bend
Well-Known Member
First Name
Justin
Joined
Apr 18, 2021
Threads
5
Messages
359
Reaction score
913
Location
Columbus Ohio
Vehicle(s)
Lexus RX
Bronco
Big Bend
Clubs
 
The parking aid assist? I’m pretty sure it will be going off but mine is faulty. I’m having a tech check it out today actually to help me. I get a “park aid fault” error on my cluster, I disconnected a harness and can’t get it back into the slot for some reason.
Was the "Park Aid Fault" something it it took a long time for the dealership to fix? Did you do it yourself?
 
OP
OP
Hazard

Hazard

Badlands
Well-Known Member
First Name
Kevin
Joined
Sep 13, 2021
Threads
3
Messages
57
Reaction score
59
Location
California
Vehicle(s)
Nissan 350z, Mitsubishi Lancer, Range Rover LR3
Bronco
Badlands
Was the "Park Aid Fault" something it it took a long time for the dealership to fix? Did you do it yourself?
In my case no but that is because I work at a dealership, I just went to one of the techs and left the bronco with him for a couple minutes. It was a small connector between the bumper and body. It’s very hard to get a hand there to mate the connectors well, plier type tools help . They end up barely touching and makes the code pop up. Here is the diagram of the connector that gave me the code

1CA30016-D923-432E-8726-AB1550587DC2.jpeg
 
OP
OP
Hazard

Hazard

Badlands
Well-Known Member
First Name
Kevin
Joined
Sep 13, 2021
Threads
3
Messages
57
Reaction score
59
Location
California
Vehicle(s)
Nissan 350z, Mitsubishi Lancer, Range Rover LR3
Bronco
Badlands
Any chance you have a picture or video of opening the tailgate with it attached?
Unfortunately I do not. Snowboard season is over so I haven’t had it mounted in well over a month as well

 

 
Top